Discuss.FOLIO.org is no longer used. This is a static snapshot of the website as of February 14, 2023.

Question for Okapi when I run runhello.sh for registering self defined module on Okapi!

13 Apr '17

When I register self defined Module on Okapi using Centos7 OS, console print exception like :
Deploying it on localhost HTTP/1.1 500 Internal Server Error Content-Type: text/plain Content-Length: 81

http://localhost:4243/images/ill-web/json: 拒绝连接: localhost/

Enabling it for our tenant
HTTP/1.1 201 Created
Content-Type: application/json
Location: /_/proxy/tenants/testlib/modules/ill-web
Content-Length: 22

  "id" : "ill-web"

then I run netstat -ntlp showing this port 4243 hasn’t been used.
But there isn’t this exception when I run the same operation using Ubantu OS .The following is my capture of DockerFile and runhello.sh and some desceriptor.json:

15 Apr '17

Thanks for reporting this problem.

I followed the hello-vertex/README.md to do the steps manually.
Yes, confirmed that it breaks at the step “deploy it via Okapi discovery”:

HTTP/1.1 500 Internal Server Error
Content-Type: text/plain
Content-Length: 98

http://localhost:4243/images/folio-hello-module/json: Connection refused: localhost/

A net search found this old issue, which sounds similar:
folio-sample-modules now not working with dockerImage in launchDescriptor

Also found this:
using systemd to configure the Docker daemon.

And in the Okapi Guide:

I am on MacOS. Need to investigate.

18 Apr '17

CentOS 7 Linux also uses ‘systemd’. Have you followed these
configuration instructions? … https://github.com/folio-org/folio-sample-modules#linux

28 Apr '17

I have followed your guide , but I haven’t solved this problem of refused localhost/
Capture like following :

3 May '17

What value do you have for “OKAPIHOST”?

Following that documentation, see the section “Other ways to get a value for OKAPIHOST”.