Skip FOLIO Project Navigation

Babel Version Wrong

Hi All,

First time Folio guy here.

I’m trying to get our app up and running and have gotten as far as actually 'yarn start’ing. However, when the server comes up I get this error:

Requires Babel “7.0.0-0” but was loaded with “6.26.3”

How to upgrade Babel for Stripes?

I did this, to no avail:

npx babel-upgrade --write

I checked:

cat ~/.config/yarn/global/node_modules/babel-loader/package.json
“devDependencies”: {
@babel/cli”: “^7.2.0”,
@babel/core”: “^7.2.0”,
@babel/preset-env”: “^7.2.0”,

Somehow, Stripes thinks I have an older version of Babel installed. No fair!

Advice appreciated,

Mark

My typical workflow for running stripes is to use a yarn workspace. I create a workspace directory with this package.json file:

{
  "private": true,
  "workspaces": [
    "*"
  ],
  "devDependencies": {
    "@folio/stripes-cli": "^1.15.0"
  }
  "resolutions": {
    "moment": "~2.24.0",
    "react-router": "4.3.1",
    "react-router-dom": "4.3.1"
  }
}

and this .npmrc file:

@folio:registry = "https://repository.folio.org/repository/npm-folioci/"

and then clone platform-core (checked out to the snapshot branch). In platform-core , copy stripes.config.js to stripes.config.js.local and update the okapi.url to point to your backend of choice, e.g.

okapi: { 'url': 'https://folio-snapshot-okapi.aws.indexdata.com/', 'tenant':'diku' },

or perhaps the URL for an okapi instance you are running locally. Then run yarn in the workspace to pull in deps, and then in platform-core yarn local to serve the build.

This will give you a tip-of-master build for both stripes and all the UI apps. If you would prefer to run with released copies, change the NPM registry to npm-folioci in the .npmrc file and leave platform-core checked out to master.

Thanks!

I think this is where its not really working for me:

“Then run yarn in the workspace to pull in deps”

Basically, I’ve been tasked with validating a build process for a Folio/Stripes app here (and on Ubuntu as opposed to Mac). The steps I’ve taken are below, but there is something not right about the Babel version that’s ultimately registered.

INSTALLING STAFF ORIOLE UI (ui-oriole-staff) ON UBUNTU

Install Git:
sudo apt-get install git

Install Github Desktop
githubDOTcom/shiftkey/desktop

Clone via Github Desktop
githubDOTcom/jhu-sheridan-libraries/ui-oriole-staff.git
will be cloned to
~/Documents/GitHub/ui-oriole-staff

Install NVM:

Kill terminal session, start new terminal session

nvm install v12.16.2

nvm use v12.16.2

nvm alias default v12.16.2

Install Yarn:
classic.yarnpkgDOTcom/en/docs/install/#debian-stable

Set up Yarn environment:
From stackoverflowDOTcom/questions/40317578/yarn-global-command-not-working
Steps

Confirm your global bin path

yarn global bin

I got: /home/username/.yarn/bin

set yarn prefix:

make sure your yarn prefix is the parent directory of your bin directory. You can confirm by running

yarn config get prefix

when I ran this, my prefix was empty, so I set it:

yarn config set prefix ~/.yarn

add the following to ~/.bash_profile or ~/.bashrc

export PATH="$PATH:`yarn global bin`"

    for zsh users, be sure to add this line to ~/.zshrc

restart your shell or start a new one

yarn global add --force sharp

cd ~/Documents/GitHub/ui-oriole-staff

yarn config set @folio:registry https://repository.folio.org/repository/npm-folio/

yarn global add @folio/stripes-cli

stripes alias add @folio/stripes-core /home/ubuntu/.config/yarn/global/node_modules/@folio/stripes-core

yarn install

yarn upgrade

npx babel-upgrade --write

yarn start

Listening at localhost:3000

Generally, I recommend using a yarn workspace (as above) over installing stripes-cli globally and using yarn aliases. Aliases, in particular, have the potential to mislead you about which instance of a library you are using when multiple copies are present and I strongly recommend against using them.

If you want to run your app in isolation, outside the context of a platform, this is still possible. Add @folio/stripes-cli as a dev-dep, create a stripes.config.js file that includes your okapi URL,

module.exports = {
  okapi: { 'url':'http://path-to-okapi.edu', 'tenant':'name-of-tenant' },
  config: {
    logCategories: 'core,path,action,xhr',
    logPrefix: '--',
    showPerms: false,
    languages: ['en'],
  },
  modules: {
    'oriole-staff' : {}
  },
}

and then run it like this:

yarn stripes serve ./stripes.config.js

Thank you! I think this is the Clue I needed.

Mark

Zak,

I am understanding this correctly, my /YarnWorkspace/ directory will have two subdirectories:
a git clone of Stripes
a git clone of my codebase, the one that’s written on top of Stripes
Is this correct?

Then, the virtues of a Yarn Workspace is that dependencies for both branches of this tree are determined and pulled down comprehensively by Yarn via ‘yarn install’.

Here is what I have:

~/YarnWorkspace$ tree
.
├── package.json
├── stripes
│ ├── CHANGELOG.md
│ ├── components
│ │ └── index.js
│ ├── connect
│ │ └── index.js
│ ├── CONTRIBUTING.md
│ ├── core
│ │ ├── index.js
│ │ └── test
│ │ └── index.js
│ ├── doc
│ │ ├── backend.md
│ │ ├── bigtest.md
│ │ ├── branding.md
│ │ ├── depending-on-unreleased-features.md
│ │ ├── dev-guide.md
│ │ ├── i18n.md
│ │ ├── modules-apps-etc.md
│ │ ├── new-development-setup.md
│ │ ├── overview.md
│ │ ├── quick-start.md
│ │ ├── release-procedure.md
│ │ ├── setting-up-a-folio-backend.md
│ │ ├── stripes-framework.md
│ │ └── troubleshooting.md
│ ├── final-form
│ │ └── index.js
│ ├── form
│ │ └── index.js
│ ├── Jenkinsfile
│ ├── LICENSE
│ ├── logger
│ │ └── index.js
│ ├── package.json
│ ├── README.md
│ ├── smart-components
│ │ └── index.js
│ ├── src
│ │ └── index.js
│ └── util
│ └── index.js
└── ui-oriole-staff
├── CHANGELOG.md
├── CONTRIBUTING.md
├── Dockerfile
├── LICENSE
├── MD.json
├── nginx.conf
├── node_modules_hacks
│ ├── EditUserInfo.js
│ ├── index.js
│ ├── LoginAdmin
│ │ ├── index.js
│ │ ├── LoginAdmin.css
│ │ ├── LoginAdminCtrl.js
│ │ └── LoginAdmin.js
│ ├── Login.js
│ ├── RootWithIntl.js
│ ├── Users.js
│ ├── ViewUser.js
│ └── withServicePoints.js
├── package.json
├── README.md
├── src
│ ├── components
│ │ ├── Main
│ │ │ ├── index.js
│ │ │ ├── Main.css
│ │ │ └── Main.js
│ │ ├── ResourceEditor
│ │ │ ├── index.js
│ │ │ ├── ResourceEditor.js
│ │ │ └── solr-test.py
│ │ ├── ResourceView
│ │ │ ├── index.js
│ │ │ └── ResourceView.js
│ │ ├── SearchableList
│ │ │ ├── index.js
│ │ │ ├── SearchableList.css
│ │ │ └── SearchableList.js
│ │ └── Sections
│ │ ├── AccessRestrictions
│ │ │ ├── AccessRestrictions.css
│ │ │ ├── AccessRestrictionsForm.js
│ │ │ ├── AccessRestrictionsView.js
│ │ │ └── index.js
│ │ ├── Availability
│ │ │ ├── AvailabilityView.js
│ │ │ └── index.js
│ │ └── TagList
│ │ ├── index.js
│ │ ├── TagList.css
│ │ ├── TagListForm.js
│ │ └── TagListView.js
│ ├── index.js
│ ├── selectors
│ │ └── resource.js
│ └── settings
│ ├── general-settings.js
│ ├── index.js
│ ├── LibrariesSettings.js
│ ├── some-feature-settings.js
│ └── SubjectsSettings.js
├── test
│ └── ui-testing
│ └── demo.js
├── translations
│ └── ui-oriole
│ └── en_US.json
├── yarn.lock
└── yarn-post-build.sh

31 directories, 82 files

You don’t need to clone stripes into your workspace; you need a platform and the repo you’re working on, e.g.

[16:53] /Users/zburke/temp/core-workspace 
$ ls -al 
total 16
drwxr-xr-x    6 zburke  staff   192 May 14 16:53 .
drwxr-xr-x  101 zburke  staff  3232 May 13 05:53 ..
-rw-r--r--    1 zburke  staff    74 Feb  6 09:30 .npmrc
-rw-r--r--    1 zburke  staff   193 Aug 28  2019 package.json
drwxr-xr-x   21 zburke  staff   672 Feb  6 09:35 platform-core
drwxr-xr-x   18 zburke  staff   576 May 14 16:53 ui-users

You could easily start by cloning folio-org/platform-core from GitHub, then gut its package.json so its deps only include your app and the package it provides to the platform:

...
  "dependencies": {
    "@jhu/oriole-staff": "^0.0.0",
    "@folio/stripes": "^4.0.0",
    "moment": "~2.25.3",
    "react": "~16.12.0",
    "react-dom": "~16.12.0",
    "react-intl": "^4.5.3",
    "react-redux": "^5.1.1",
    "react-router": "^4.3.1",
    "react-router-dom": "^4.3.1",
    "redux": "^3.7.2"  
  },

and stripes.config.js as well:

module.exports = {
  okapi: { 'url':'https://url.to.okapi.edu', 'tenant':'jhu' },

  config: {
    logCategories: 'core,path,action,xhr',
    logPrefix: '--',
    showPerms: false
  },
  modules: {
    '@jhu/oriole-staff' : {}
  },
  branding: {
    logo: {
      src: './tenant-assets/opentown-libraries-logo.png',
      alt: 'Opentown Libraries',
    },
    favicon: {
      src: './tenant-assets/folio-favicon.png',
    },
  },
};

Then, you could run your platform by cd’ing into the platform directory and running

yarn stripes serve stripes.config.js

(I don’t know if you have your apps namespaced under @jhu. We happen to namespace ours and run our own npm server, but obviously you don’t have to do that.)

Honestly, the easiest way to get going may be the following:

  1. start with an empty directory to use as a workspace
  2. copy in the .npmrc and package.json files referenced way up top in “my typical workflow”
  3. clone folio-org/platform-core from GitHub and checkout its snapshot branch
  4. update platform-core’s stripes.config.js so okapi.url points to https://folio-snapshot-okapi.aws.indexdata.com (our nightly build)
  5. cd into the workspace, run yarn
  6. cd into the platform, run yarn stripes serve stripes.config.js
  7. visit http://localhost:3000

This will give you a local stripes instance pointed at our nightly build. From there, you could clone one of the UI apps listed in the platform’s package.json, e.g. ui-developer, make a change to a file like src/settings/Configuration.js and then see that change reflected in your browser at http://localhost:3000/settings/developer/configuration.

Once you have that rolling, then clone your own app into the workspace and add it to the platform’s package.json and stripes.config.js.

Good luck!

Thanks, Zak! This is extremely helpful!

Mark

So close! But it’s not executing the Stripes CLI:

$ yarn stripes serve stripes.config.js
yarn run v1.22.4
$ stripes serve stripes.config.js
/bin/sh: 1: stripes: not found
error Command failed with exit code 127.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
%u

So far, here are my steps:

Install Git:
sudo apt-get install git

Install Yarn:
https://classic.yarnpkg.com/en/docs/install/#debian-stable

Install npm:
sudo apt-get install npm

Make and enter Yarn Workspace directory:
mkdir YarnWorkspace
cd YarnWorkspace

Copy the following package.json file into the YarnWorkspace directory root:
{
  "private": true,
  "workspaces": [
    "*"
  ],
  "devDependencies": {
    "@folio/stripes-cli": "^1.15.0"
  },
  "resolutions": {
    "moment": "~2.24.0",
    "react-router": "4.3.1",
    "react-router-dom": "4.3.1"
  }
}

Clone Oriole
git clone https://github.com/jhu-sheridan-libraries/ui-oriole-staff.git

Clone Folio platform
git clone https://github.com/folio-org/platform-core.git

Add the following under "dependencies" in /platform-core/package.json:
"@jhu/oriole-staff": "^0.0.0",

Add the following under "modules" in /platform-core/stripes.config.js:
'@jhu/oriole-staff' : {}

In that same file, the "okapi" entry should be:
okapi: { 'url':'https://api-dev.databases.library.jhu.edu', 'tenant':'jhu' },

Boot up the app, from within /platform-core/:
yarn stripes serve stripes.config.js+_h!3

I’m thinking Stripes CLI should have been installed as a dependency???

The dev-dep on stripes-cli will give you stripes (yeah, the naming of things is confusing; long story; sorry). Did you miss step 5? That’s the step that installs all the dependencies:

Nice! Progress!

And yet, I’m getting a ton of deprecation warnings, and Stripes-CLI is not found. The one warning I’m most concerned about this this one, not finding the locally cloned Oriole codebase:

error Couldn't find package "@jhu/oriole-staff@^0.0.0" required by "@folio/platform-core@4.4.0" on the "npm" registry.

But I’m reading through others trying to see where/why there is no Stripes-CLI:

yarn install v1.22.4
info No lockfile found.
[1/4] Resolving packages...
warning @folio/stripes-cli > karma > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning @folio/stripes-cli > karma > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning @folio/stripes-cli > mocha > mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
warning @folio/stripes-cli > karma > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
warning @folio/stripes-cli > karma > log4js > circular-json@0.5.9: CircularJSON is in maintenance only, flatted is its successor.
warning @folio/stripes-cli > babel-plugin-istanbul > istanbul-lib-instrument > babel-traverse > babel-runtime > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning @folio/stripes-cli > webpack > watchpack > watchpack-chokidar2 > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning @folio/stripes-cli > @folio/stripes-core > @folio/stripes-components > popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
warning @folio/stripes-cli > @folio/stripes-core > @folio/stripes-components > react-highlight-words > memoize-one@4.1.0: New custom equality api does not play well with all equality helpers. Please use v5.x
warning @folio/stripes-cli > @folio/stripes-core > hard-source-webpack-plugin > jsonlint > nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
warning @folio/stripes-cli > kopy > micromatch > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
warning @folio/stripes-cli > kopy > micromatch > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
warning @folio/stripes-cli > @folio/stripes-core > favicons-webpack-plugin > favicons > to-ico > resize-img > jimp > mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
warning @folio/stripes-cli > @folio/stripes-core > @folio/stripes-components > react-quill > create-react-class > fbjs > core-js@1.2.7: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning @folio/stripes-cli > @folio/stripes-testing > nightmare > electron > electron-download > nugget > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
warning @folio/stripes-cli > @folio/stripes-core > favicons-webpack-plugin > favicons > to-ico > resize-img > jimp > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
error Couldn't find package "@jhu/oriole-staff@^0.0.0" required by "@folio/platform-core@4.4.0" on the "npm" registry.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-components > popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > babel-preset-es2015@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read https://babeljs.io/env to update!
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > babel-polyfill > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin@2.7.1: webapp-webpack-plugin has been merged back to favicons-webpack-plugin, use it instead.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/custom > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/types > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/custom > @jimp/core > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/custom > @jimp/core > mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-blit > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-blur > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-color > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-contain > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-cover > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-crop > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-displace > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-dither > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-flip > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-gaussian > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-invert > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-mask > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-normalize > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-print > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-resize > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-rotate > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/plugins > @jimp/plugin-scale > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/types > @jimp/bmp > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/types > @jimp/gif > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/types > @jimp/jpeg > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/types > @jimp/png > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/types > @jimp/tiff > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @jimp/custom > @jimp/core > @jimp/utils > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/platform-core > react-intl > intl-relativeformat@2.2.0: This package has been deprecated, please see migration guide at 'https://github.com/formatjs/formatjs/tree/master/packages/intl-relativeformat#migration-guide'
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > babel-core > babel-register > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @babel/polyfill@7.8.7: 🚨 This package has been deprecated in favor of separate inclusion of a polyfill and regenerator-runtime (when needed). See the @babel/polyfill docs (https://babeljs.io/docs/en/babel-polyfill) for more information.
warning workspace-aggregator-262f1ab5-2649-4fcd-8438-90fedad1a010 > @folio/oriole > @folio/stripes > @folio/stripes-core > webapp-webpack-plugin > favicons > jimp > @babel/polyfill > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
Error: Couldn't find any versions for "@folio/calendar" that matches "3.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/plugin-find-user" that matches "2.0.1"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/developer" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/myprofile" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/plugin-find-instance" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/servicepoints" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/stripes" that matches "3.1.2"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/tags" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/checkout" that matches "3.0.2"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/search" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/tenant-settings" that matches "3.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/requests" that matches "2.0.3"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/checkin" that matches "2.0.1"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/circulation" that matches "2.0.0"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/inventory" that matches "2.0.2"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)
Error: Couldn't find any versions for "@folio/users" that matches "3.0.4"
    at MessageError.ExtendableBuiltin (/usr/share/yarn/lib/cli.js:721:66)
    at new MessageError (/usr/share/yarn/lib/cli.js:750:123)
    at Function.<anonymous> (/usr/share/yarn/lib/cli.js:50545:13)
    at Generator.next (<anonymous>)
    at step (/usr/share/yarn/lib/cli.js:310:30)
    at /usr/share/yarn/lib/cli.js:321:13
    at process._tickCallback (internal/process/next_tick.js:68:7)

(I realize these last Folio packages are actually not needed. I intended to go through weeding once I had a running instance…)

I’m glad you’re making progress. Many of those build warnings are expected. Eliminating deprecated packages is a real challenge as many of them come in via transitive dependencies and thus are beyond are immediate control.

The build errors, however, are a different story. It looks like you have your .npmrc file pointed at npm-folioci but your platform branch is checked out to the master branch, which includes dependencies on absolute versions, e.g. "3.0.0" rather than version ranges, e.g. ^3.0.0. That’s the cause of the error messages such as

Error: Couldn't find any versions for "@folio/calendar" that matches "3.0.0"

It also looks like there may be some confusion about how your own packages are namespaced. I see both @folio/oriole and @jhu/oriole-staff, i.e. two different namespaces. Are you certain that’s correct? It could be fine, but it seems likely to be an error.