Folio installation.

Working on install NOLANA R3-2022-GA

Error in install manual at point :

Deploy the backend modules

Deployment failed for service mod-pubsub-2.7.0. Could not connect to localhost:9145: finishConnect(…) failed: Connection refused: localhost/127.0.0.1:9145

I have done all changes for IP address,port & reuploaded it with curl.
In mod-pubsub-2.7.0 I can’t find configuration for port “9145”.

Any clue where to look?

Do a

sudo docker ps --all

and see what module is running on which port.

Thanks for reply.
I did a full reinstall.

Now I’m stuck with bootstrap-superuser.pl

This is output from terminal :

root@folio-nolana:/etc/folio/platform-complete# perl bootstrap-superuser.pl --tenant diku --user diku_admin --password admin --okapi http://10.140.19.74:9130
Finding module ID for authtoken…OK
Disabling authtoken for tenant…500 Internal Server Error

Before that I got error :
No running instances for module mod-inventory-storage-25.0.4. Can not invoke /_/tenant

More info. All required modules in bootstrap-superuser.pl are present in docker :

root@folio-nolana:/etc/folio/okapi# docker ps --all | grep mod-aut
26deb8acae85 folioorg/mod-authtoken:2.12.0
root@folio-nolana:/etc/folio/okapi# docker ps --all | grep mod-user
9da31862112c folioorg/mod-users-bl:7.4.0
5908053c89da folioorg/mod-user-import:3.7.1
71df9c325e96 folioorg/mod-users:19.0.0
root@folio-nolana:/etc/folio/okapi# docker ps --all | grep mod-log
761849b274a9 folioorg/mod-login-saml:2.5.0
eff1c4aad0ea folioorg/mod-login:7.8.0
root@folio-nolana:/etc/folio/okapi# docker ps --all | grep mod-permi
5cf78b568f77 folioorg/mod-permissions:6.2.0
root@folio-nolana:/etc/folio/okapi# docker ps --all | grep mod-inven
e980b9370033 folioorg/mod-inventory-storage:25.0.3
2a141061c858 folioorg/mod-inventory-update:2.3.1
cb4757140f17 folioorg/mod-inventory:19.0.2
root@folio-nolana:/etc/folio/okapi# docker ps --all | grep mod-users
9da31862112c folioorg/mod-users-bl:7.4.0
71df9c325e96 folioorg/mod-users:19.0.0

Hi.
Looks like there is a mismatch in your module version of mod-inventory-storage, mod-inventory-storage-25.0.4 for Okapi tenant vs. mod-inventory-storage-25.0.3 in Docker. Check the version of mod-inventory-storage of your tenant:
curl -w ‘\n’ -XGET http://localhost:9130/_/proxy/tenants/diku/modules | grep mod-inventory-storage
Is it mod-inventory-storage-25.0.3., the R3-2022 GA version ?

Yes, currently I’m trying to install R3-2022-GA , but so far no luck.
Will try to install now R2-2022-hotfix-1.

I have a question about default configuration for modules.
For example in module : mod-users-19.0.0.json

  "name" : "DB_USERNAME",
  "value" : "folio_admin"
}, {
  "name" : "DB_PASSWORD",
  "value" : "folio_admin"
}, {
  "name" : "DB_DATABASE",
  "value" : "okapi_modules"

If I follow install manual posted for Nolana version, then there’s is completely different configuration.

In install manual :

CREATE ROLE okapi WITH PASSWORD ‘okapi25’ LOGIN CREATEDB;
CREATE DATABASE okapi WITH OWNER okapi;

CREATE ROLE folio WITH PASSWORD ‘folio123’ LOGIN SUPERUSER;
CREATE DATABASE folio WITH OWNER folio;

There’s no mention about database “okapi_modules”.
This database configuration with “okapi_modules” is default in almost every module.

So , as I understand , I must to edit every module and change database, user & password e.t.c?

No, you don’t have to edit this. Okapi somehow automagically replaces “folio_admin” and “okapi_modules” (and others) by the values that you have set in the Okapi environment. Check your Okapi environment : curl -X GET http://localhost:9130/_/env . If some names are missing or some values are misconfigured, you have to set them like this, e.g. for DB_PASSWORD,
curl -w ‘\n’ -D - -X POST -H “Content-Type: application/json” -d “{"name":"DB_PASSWORD","value":"folio123"}” http://localhost:9130/_/env
. You have to do this before you deploy the modules (if you deploy with Okapi, which you do since you follow the install guide).

Hi. I’m still getting error about mod-pubsub-2.7.0
When I grep docker output for 9145 port, there is no container with such port.

\env file output and error is in screenshot, because I can’t post more than 2 links.

Hi. Now I have tried installing from folio ansible playbook.

Install process stops on :

TASK [edge-module : Assign permissions to innreachClient]
failed: [192.168.1.20] (item=inn-reach.all) => {“ansible_loop_var”: “item”, “changed”: false, “connection”: “close”, “content_type”: “text/plain”, “elapsed”: 0, “item”: “inn-reach.all”, “msg”:
“Status code was 400 and not [200]: HTTP Error 400: Bad Request”, “redirected”: false, “status”: 400, “transfer_encoding”: “chunked”, “url”: “http://192.168.1.20:9130/perms/users/d03f126a-d061-445c-9c7f-33a4cbeb9986/permissions”}

I add option : “ignore_errors: yes” in edge-module : Assign permissions to innreachClient.

Continue playbook with command :
ansible-playbook -u ansible -i inventory.yml folio.yml --start-at-task=“edge-module : Assign permissions to innreachClient”

Next error :

TASK [ldp : Enable postgresql trigram support]
fatal: [192.168.1.20]: FAILED! => {“changed”: false, “msg”: “Cannot execute SQL
‘CREATE EXTENSION pg_trgm’ None: extension "pg_trgm" already exists\n, query list: [‘CREATE EXTENSION pg_trgm’]”}

Remove mod-innreach from the list of modules (cd ~/platform-complete/. grep “inn-reach” *.json). This module has been removed from the platform.

Thanks. That worked. :+1: