Skip FOLIO Project Navigation

Some modules required by mod-users-bl can't found on github


#1

Are those modules back-end or front-end for {
“id” : “service-points”,
“version” : “2.1 3.0”
},
{
“id” : “service-points-users”,
“version” : “1.0”
}
Why I can’t find those on https://github.com/folio-org


#2

mod-users-bl is a back-end module, so it can only depend on back-end modules. Here, assuming you’re referencing requirements from its module descriptor, it is expressing a dependency on an interface, not on a particular module. That is, mod-users-bl requires modules to be present that provide the interfaces service-points at version 2.1 or 3.0 and service-points-users at version 1.0.

A good place to figure out which modules provide which interfaces is the API documentation where the interfaces are listed as API endpoints. In this case, it shows both interfaces are provided by mod-inventory-storage. You can click the endpoint links to see the RAML files directly in their host repositories on GitHub.

HTH,

Zak


#3

Okay, thank you very much, Zak.
I have known a lot according to your clarifications.
Meanwhile, Adam also explained as you said on slack just know.
Thanks!


#4

@zburke
Okay, thank you very much, Zak.
I have known a lot according to your clarifications.
Meanwhile, Adam also explained as you said on slack just know.
Thanks!