Skip FOLIO Project Navigation

stripes ui-users running problem


#1

Hi!!

We are following the “Getting started guide” to run folio. But we have one problem. When we run the front-end ui-user proyect with stripes and “yarn install”. And then, see it in the browser (localhost:3000), has the next error:

Then we follow the recomendations to use the command “yarn install --flat” and resolve the duplicated packages. When we finished, we use the command “yarn start” to run it again, but it displays another error:

we are using system enviroment:
-Windows 10
-yarn version: 1.10.1
-node version: v8.12.0
-npm version: 6.4.1


#2

Thanks for bringing this to our attention. The module ui-trivial needs to be updated because it is pulling in an old version of React, in conflict with other modules, and that is causing the duplicate-package warning you see. I’ll post a follow-up message here as soon as this is fixed.


#3

This should be resolved. We made a new release of ui-trivial (v1.3.0) and updated the version dependency in stripes-sample-platform. Sorry for the trouble!