Skip FOLIO Project Navigation

Vendor app in FOLIO


#1

Hi everyone,

The vendor app is live in FOLIO. Now it needs review and testing. We know there are pieces that still need refining, and that work continues behind the scenes. But we also need your feedback on the app, so that we can ensure it meets the community’s expectation for functionality and that we catch as many bugs as possible before libraries begin implementing.

To get to the vendor app, go to http://folio-snapshot-stable.aws.indexdata.com/, log on with user name diku_admin, password admin. Then go to the vendor app in the top menu bar.

We have created some sample vendors, representing a range of vendors - large and small, international, P/E, governmental entity, etc. Keep in mind that this sample data is refreshed every time the FOLIO environment is refreshed, usually daily. That means any changes you make - adding new vendors, editing existing vendors - will be wiped out when the data is refreshed.

Please exercise the app:

  • Build a new vendor
  • Edit an existing vendor
  • Search for vendors
  • Try the various filters

Leave your feedback in the comments below. Do you understand all the fields in the vendor record? Are there things you like? Don’t like? That should perhaps work differently? Is there anything missing? We’ll work on any bugs, and address any questions or comments about additional or differing functionality.

We expect that there will be more formal User Acceptance Testing, but we’re interested in starting with your initial feedback and first impressions.

It’s exciting to have this first piece of FOLIO Acquisitions live! Now we make it awesome.


#2

Thanks for starting the Discuss post, Anne-Marie! I will be asking Duke staff who work with vendor records currently to review and provide feedback.

One quick item from me is that I would prefer the filter options to start out collapsed. On my small screen (using a laptop today) the first filter option takes up all of the space under the search in the left frame. Also, getting through all of them to filter by vendor status at the end requires too much scrolling.


#3

Okay, I promise not to start a new comment for every bit of feedback I have, but I did play around briefly and noticed an issue.

I attempted to edit the Taylor & Francis record by adding an Alternative Name. I added the AKA then selected “Update Vendor.” The only response to my clicking the button was that it turns a darker blue. Not sure if I had successfully saved the change to the record or not, I clicked on the X in the upper lefthand corner of the screen to close the record. I got a prompt telling me that my changes weren’t saved and asking if I wanted to exit the record anyway. I said no, the screen closed, then I tried clicking on the “Update Vendor” button again. Still no change other than the button changing to a darker blue. I went to try again to close out of the record, and now the X neither closes the record nor triggers a pop up asking me if I am sure I want to leave because I have unsaved changes.

FWIW, I tried this in both Firefox and Chrome and had the same result.


#4

Interestingly, I was able to create and save a new vendor, and even edit the new vendor and save it. But when I tried to update an existing vendor (I tried both Alexander Street and EBSCO), I am having a similar experience to Virginia, in that clicking “Update” does not save the changes.


#5

Thanks, Ann-Marie, for the discuss post and feedback opportunity!
The app seems very nice, my colleagues and I will have a closer look and do some detailed testing this week.

But I do already have some small feedback/questions on the filter functionalities, that seem important to me:

  • It would be great to collapse the filter catagories by default. It takes a while to scroll down (esp. the country list), just like @VirginiaMartin writes.
  • There seems to be no way to search for the name of a vendor’s contact person. For me, this might be really helpful, e.g. when I receive an e-mail or call and want to look up some details on the contact. Of course I could also search for the vendor and then open the contact section, but it would be nice not to have to.

EDIT: I experience exactly the same update/close issues for existing vendors Virginia described.


#6

Here is a comment from our Head of Acquisitions: “Was able to easily add in a new vendor. One thing I did not like – having the EDI code a mandatory field. That will not apply to many vendors. I made something up to satisfy the field requirement. Everything else was fine.”


#7

Hi Virginia,

Thanks for the suggestion. I agree about starting with the filters closed - I hate having to scroll to see all the filters. Maybe also rearranging so that the active/inactive filter is at the top. I’m starting a list to review with Dennis and the Acq Small Group.

A-M


#8

I was unable to edit some vendors and saw the same behavior first identified by Virginia. I was also only able (in Firefox) to navigate via the scroll bar on the side. Page Up and Page Down, or up and down arrow did not move me through the page.

For some of our large vendors, we have multiple accounts (and within accounts subaccounts). For example, with one vender we have two accounts one of which has over 60 billing subaccounts. Is it possible to change the AP vendor number via a bulk edit (even frequently used numbers can change occasionally).


#9

Virginia and Kristin:

Interesting that editing an existing vendor hangs, but you’re able to create and edit a new vendor. We’ll log that as a bug.

Virginia: it’s actually probably easier to make a new comment for each different feedback, so no worries if there end up being lots of comments!

And Chrome is definitely the preferred browser for FOLIO.


#10

Annika:

Thanks for confirming the edit problem and collapsing the filter categories.

Thanks also for the suggestion of searching by a contact person. We were assuming you would know the vendor, search the vendor, and scroll down to the contact details.

Question: Do other folks think it would be helpful to be able to search by contact name?


#11

Yes, searching by a contact name is helpful.


#12

Kristin:

re: EDI being a required field. Are you sure that’s happening? Could they try again? I just tried creating a new vendor, and was able to do it with just the vendor name, absolutely no other data.

That said, it seems like we should ensure any required fields have an asterisk next to them.


#13

Some comments by our Head of Payments:
When adding address and contact information, I was not sure how to add more than one category to the same information. Is that possible? For example, if the contact information is the same for both orders and payments, can you add the address once and select both categories, or do you have to add it twice and assign one category to each?

If I wanted to print or download a list of vendors, perhaps one that I had filtered, is that possible? Would I be able to select fields to include in the download?

All in all, I thought it was pretty straight forward and simple to use and navigate. I would agree with the individuals who suggested that the search filters be collapsed as the default rather than open.


#14

I also created a new vendor without anything in the EDI field.


#15

Scott:

As of now, Chrome is the most stable environment for FOLIO. I’m not sure what the current Product Council thinking is in terms of support via Firefox or other browsers. Definitely best to test (for now) via Chrome.

For now, there are not any bulk edit options anywhere in FOLIO, though I know that’s planned at some point. I’ll take a note on the accounts and we’ll discuss.


#16

[Good! And the point on collapsing the search filters is noted.


#17

I second Scott’s suggestion that we be able to print or export a list of vendors that has been filtered. This functionality is available in Aleph (though somewhat cumbersome) and is invaluable for quick “reporting.”


#18

Thanks, Virginia - noted.


#19

Hi Ann-Marie,

This is great! The app is already fun to use. I was not sure to what details you need feedback a this point os there might be points in my notes that are a bit “over the top”:

  • In general the app feels easy to use. I experienced very few glitches using Chrome
  • When setting up a second email address for a vendor the app was not able to update the vendor record. I tried this several times.
  • Generally the default language could be set to English and not Afar
  • When you review a vendor record and expand several sections and than click on the edit button the same sections should be expanded on the edit-screen and the screen could show the same section you were reviewing before (so the user does not have to scroll down again)?
  • For the contact information there is no ZIP-code field. Is this on purpose? Does the display work for UK addresses
  • The country dropdown under “Contact people” -> “Address” is not working for me. I cannot choose any values.
  • Does the URL for a contact person need to be mandatory?
  • The country code for the phone number is missing a leading “+” or “00”
  • I don’t understand the display in the “FTP Details” section
  • For OH interfaces it would be useful to note the coordinator for the interface account. Every user has their own login so only displaying one might be confusing in this section. The coordinator is the person from the institution who has the permissin within our systems to set up a new user or assign additional permissions.

I hope this is somewhat useful. Let me know if you have any questions.
Sebastian


#20

Hi Ann-Marie,

thank you for editing this post and taking care of our feedback. To my mind, the vendor app is great and easy to use.

Here are just some bits and bobs:
I agree to @annikadomin, that being able to search for a contact name would be great.
Then I had the same problem as @Sebastian in selecting a country for contact people. Same applies to selecting a default language for contact people (although both required).

In almost every section you can “add” information which is great. Is there a limit?

When you ask for a claiming interval (vendor information), could you add that this is entered in days (in a former system we would have entered the number of weeks)?

This is just a bagatelle, but in the filter section, there is a typing error in “technical support”.

I asked some colleagues for further feedback and will let you know what they think.
Thank you!